1. Does your Pi boot to EmulationStation?
Yes. All is good there.

2. Can you see the ROMs under the appropriate emulator? If not, I would suggest checking compatibility, here for FinalBurn Alpha and here for MAME.

3. Does the controller work on the EmulationStation home screen? I’ve not used the iPac 2 so I can’t help you with any specifics where. However have you read this thread? Alternatively, a temporary solution might be using a different controller. I’ve got a couple CSL gamepads, they’re not ideal for MAME and arcade stuff but you can assign the buttons however you like.

I’m using Happ arcade buttons. Old school arcade no controller. Everything works in the Emulationstation menus. When I enter any rom it’s says my iPac2 is not set up. I’ve updated the firmware for the iPac2. I’ve add all the inputs for player 1 under the retroarch.cfg. I’ve set up the buttons in the mame menu using the TAB key but they don’t stay. I’ve tried using the Retroarch setup screen but my buttons don’t work so I can’t set anything. My trackball doesn’t work at all. It did for a while when I loaded up the .94 roms for AdvMame but now it doesn’t. I switched back to the 037b11 rom set for mame4all but now those don’t work at all. With AdvMame not all the games work. So I tried lr-mame2003 and that works but I can’t configure the buttons in Retroarch so it doesn’t REALLY work. I’ve also updated to RetroPi 3.5.
I dunno what to do anymore. Maybe I’m just doing it ALL wrong. I wish I could just send this thing out and have it all done for me because I dunno what to do anymore.

4. Do the ROMs boot? If so, have you setup you controller to take credits? I was stuck trying to use the default keys for ages, for which I suggest reading.
See above.