Hey Ttown209 it worked for me, I see you copied the line eaxctly i had to change it to my vendor/product code. are you sure your vendor/product code is the same as feederchains? mine was different i followed this post below to find my vendor/product code

OK… so monchote…. you sparked something in my brain with your talk of quirks. Or at least that patch you referenced.

While I has dealing with this months ago I remembered reading something about adding a quirk on boot. But I didn’t get it to work. Looking back now, it’s because I didn’t know what I was really doing then.

Anyway… So I figured out my vendor/product ids 1292/4745.

Which is when the spark happened. So you are allowed to add the following to the end of /boot/cmdline.txt


The first two numbers are my vendor/product. The third is the quirk. Found here http://lxr.free-electrons.com/source/include/linux/hid.h#L313

So the 40 is for multi input.

So with my kernel and this above. I was seeing two controllers and they both worked.

You can find the vendor/product using

returned this for me
Bus 001 Device 005: ID 1292:4745 Innomedia

So the next logical step was to try and use HID_QUIRK_NOGET with a virgin kernel and see if the directionals work. Replaced the 40 with the 8.

Unfortunately that didn’t work for me.

Hopefully for you compiling in the quirk will help.