Anonymous
Inactive
Post count: 3

I found that retroarch handles the axis inputs differently than jstest, which could be the reason for retroarch closing prematurely upon reaching the input prompt screen with the NeoGeo X joystick. When I run retroarch-joyconfig with -d linuxraw I am able to receive input from the NeoGeo X joystick. Unfortunately this did not produce a config file for the joystick. So I created a NeoGeoX.cfg file in the retroarch-joypads directory and ran retroarch-joyconfig using the following commands:

./retroarch-joyconfig -d linuxraw -o /opt/retropie/configs/all/retroarch-joypads/NeogeoX.cfg

This basically forced the output of retroarch-joyconfig to the specified directory, which it did so successfully. But this is where I ran into bigger problem, the output that was written to the NeoGeoX.cfg was missing all of the device information and the config information recorded was missing the axis inputs as well.

This brings me back to the format in which udev records axis inputs vs linuxraw.

Tomorrow I will try to find and install an older version of retropie that supposedly has better linuxraw support already in retroarch and compare the retroarch config files.