Post count: 10

I had the bad sixaxis buffer (out of battery) including the sequentially flashing of the lights since retropie 2.6 (before that i had no trouble connecting 2 ps3 controllers over bluetooth), even though i use original ps3 controllers and a working bluetooth dongle.

In Retropie 2.6 i fixed it like this:

Via the retropie setup (RetroPie-Setup/ menu I chose setup and after that I installed PS3 controller driver-mod 315 (instead of the usual ps3 controller driver 314). After it installed I did another sixpair command and after a reboot it worked (and kept working). So I guess it had something to do with the original driver not being compatible with 2.6, it did however worked with 2.5.

In the latest Retropie (3.0 beta 4) this option isn’t available anymore. So the only way I could fix it was by setting legacy to 2:

go to


sudo nano sixad

set legacy = 2

save, then:

sixad –stop
sixad -s

After reboot, everything works and I can pair 2 controllers (I haven’t tested more), however according to sixad forums you lose the accelerometer or rumble). The leds work but the rest I haven’t yet noticed. I hope in future versions of retropie the problem gets fixed permanently.