Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Echo
    Participant
    Post count: 6

    Hey,
    I use the Gpio Adapter for my Raspberry pi. Everything worked fine but i had to switch the sd Card so i used the “RetroPie Project SD card Image” to set up my Pi. Emulators work fine also the pads. But i cant close a running game with the gpio Adapter button or with the keyboard Esc Button. I checked the config file if there is a problem but it looks fine escape is set to close a running game. Shutting down the emulation station by pressing 5 times works fine. Maby i forgott something.
    Echo

    petrockblog
    Keymaster
    Post count: 1827

    You need to enable SNESDev manually for the SD card image. To enable both, game pads and the button, you need to choose the option “Enable SNESDev on boot and SNESDev keyboard mapping (polling pads and button).” from within the RetroPie Setup Script.

    Echo
    Participant
    Post count: 6

    Thats what i have done it does not work. Pressing 3 times triggers escape but the Game wont shut down.

    petrockblog
    Keymaster
    Post count: 1827

    Can you tell me the emulated system and the game to reproduce this?

    Echo
    Participant
    Post count: 6

    I use the snes Emulator but it does not depend on a game (F-zero, streat fighter 2 Turbo, legend of zelda 3, super metroid non of them close by presing escape) or the emulator i also checkt the Nes Emulator and some games (zelda 1, zelda 2, super mario 3 same here games wont close). hope that helps.

    petrockblog
    Keymaster
    Post count: 1827

    Ok. I will try to reproduce this on my side as well. I hope to finish this by tomorrow!

    BTW: You only mentioned RetroArch-based emulators. Do you also have this failing ESC behavior with the DGEN emulator (Megadrive/Genesis)?

    Echo
    Participant
    Post count: 6

    Didn’t checked those but going to but i figured out how to close a running game by accident pressing start and select at the same time does the job how can i change that to the button?

    petrockblog
    Keymaster
    Post count: 1827

    I had a look into this issue now. You need to edit /home/pi/RetroPie/configs/all/retroarch.cfg to have these lines:

    #input_save_state_btn = 4
    #input_load_state_btn = 5
    #input_enable_hotkey_btn = 6
    #input_exit_emulator_btn = 7
    #input_rewind_btn = 3

    Basically, this disabled the hotkey functionalities of the game pads and RetroArch listens to the keyboard again. I will update the RetroPie Script and the SD-card image accordingly, so that they work out-of-the-box with the RetroPie GPIO Adapter again.

    Echo
    Participant
    Post count: 6

    all set like this but still the button does not work. But that is ok because now i can use the controller.
    PS: is there any change to get a retro pi case in the near futer black would be awsome :D

    flattery
    Participant
    Post count: 6

    A RetroPie case could be cool, but it would need to be big enough to accommodation a USB HUB and what ever else people might want in it. Or their could be a few different sizes.

    I would probably buy one and build a second RetroPie… not sure what I would do with it then…

    Echo
    Participant
    Post count: 6

    I was talking about the existing one (https://www.petrockblock.com/shop//products/702089-petrockblog-pie-acrylic-case) i want one :D but they are not in stock at the moment.

    flattery
    Participant
    Post count: 6

    Oh, I don’t think I knew about that.

    Nice, but I would like one where I could fit a usb hub inside.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.