Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • otah007
    Post count: 1

    I’ve installed Retropie via the script and chose the binary install. The default games of Cavestory and Doom work fine, as do any others I play. The problem arises when there are roms inside multiple folders – if i have roms in both the NES and SNES folders I get a black screen, but if I have games in only one or the other everything works fine!

    By black screen I mean after it says ‘Emulation Station – Loading…” the screen goes black, however all controls work as normal. I can still select an emulator and game even though the screen’s black – the only thing I can see is ‘CHOOSE’ in white at the bottom when I have an emulator with games selected. The game then opens in a separate terminal (access by pressing CTRL+ALT+1/2/3 etc.) and it plays just like normal.

    My solution for now is to change the names of the folders I don’t want to play from, making them unrecognised to Retropie. I’m not concerned about writing a script for it as that’s quite simple, I’d just rather know beforehand whether this is a known issue or if I have to do the source-based install perhaps?

    Also any anti-lag tips would be nice :D

    Post count: 14

    Change output to 720p or even vga if you have 1080p. Helped me a lot with graphical issues.

    Post count: 14

    how to change mode you can find here for vga
    720p is

    Professor Woland
    Post count: 908

    This happened to me today but I found that going to the Retropie config and updating absolutely everything fixed it.

    Post count: 908

    This happened to me after trying to add some pax roms. The emulation station splash screen will freeze and start blinking sometimes too. I removed the games I added and am still having the issue.

    I’ve changed my VGA/over scan settings to 1/1/1 and 1/19/1 with no luck. This error only occurs on my 1080p HD TV. The 720 TV which I’d prefer not to use does not do it.

    Post count: 4

    Obligatory Linux forum entry: Me too! ;-)

    Exactly the same thing here – just to let you know there’s another one with that problem. I’m still investigating and trying different things to reproduce the problem, no luck so far, but for now I agree that it looks like it has something to do with ROMs in the corresponding folders.

    [quote=56881]This happened to me today but I found that going to the Retropie config and updating absolutely everything fixed it. [/quote]

    I tried that, no change at all. Further I updated the underlying Raspbian (I’m using the RetroPie SD Card Image) with
    sudo apt-get update && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y

    I looked through the “usual suspects” in /var/log, but couldn’t find anything special so far. Are there any other logfiles to look for? If so, which ones could be the most important for this issue?

    Right now I’m doing a complete, clean installation on a different SD Card, I’ll try to tinker with the HDMI-/resolution-settings, later I’ll try it on my secondary RPi. I’ll let you know when I find something.

    BTW: Absolutely awesome work on that stuff! Now it just needs to work for me… :-)

    Post count: 12

    What’s your memory split? If I have memory split set to 384 I cannot run emulation station in 1080p. For 1080p I have to change the memory split to 256.

    Post count: 4

    [quote=61414]What’s your memory split? If I have memory split set to 384 I cannot run emulation station in 1080p. For 1080p I have to change the memory split to 256.[/quote]
    It’s the default 256/256.

    [quote=60551]I removed the games I added and am still having the issue.[/quote]
    I reproduced the problem by copying all the ROMs I have to the corresponding folders. However for me it does work again if I remove all those files.

    So I’m pretty sure it’s either a problem with one or more ROM(s) itself or maybe with a ROM’s filename including some special character or character combination that ES can’t handle for some reason. Finding out which one(s) will be kind of a tedious task…

    ES’s Logfile (~/home/pi/.emulationstation/es_log.txt) isn’t much help either, it seems there’s nothing of interest in it. The only error:

    lvl1: Error - folder with path ""/home/pi/RetroPie/roms/esconfig"" is not a directory!

    However this does also appear with ES working fine, so that’s probably not the source of the problem.

    Post count: 4

    OK, that’s a really weird problem…

    I thought it might be a specific ROM or its filename, so I put an image of an updated, working RetroPie (without any ROMs except the preinstalled stuff) on the SD card.

    Instead of copying all my ROMs for the different systems at once I copied them seperately for every system: I quit ES and started with “amiga”, started ES again, checked if everything worked, rebooted and made sure everything still worked. Then I quit ES again, went on with “amstradcpc”, checked, rebooted and so on.

    Finally I thought I found something:

    The problem occured after copying some N64 ROMs in the corresponding n64 folder. Now I deleted them one by one by exiting ES (F4), deleting a single file and restarting ES. The problem persisted until the n64 directory was completely empty. Now every N64 ROM I copied back in caused the problem.

    Now I thought I figured out what was happening:

    The problem seemed to be caused either by files themselvers or their filename. If you copy such a file into a ROM folder and ES looks for it while starting, something crashes – I thought it might be a problem concerning a regular expression of some kind, maybe one that’s looking for the file extension. Furthermore there seemed to be some kind of “cache file” (which I wasn’t able to locate so far) for every ROM folder containing the filenames, which gets damaged/inconsistent/broken in the process.

    That would explain Will’s report of not solving the problem by removing the freshly added games. It seemed if the “broken” directory is completely empty, the corresponding broken cache file won’t be opened and everything works fine. If you put any file (regardless of its name) in there afterwards, everything will stop working again, because the cache is accessed.

    Now I just needed to find out which file caused the error, so I put my clean SD card image back on and copied my N64 ROMs one by one, stopping ES before, starting it afterwards and then additionally rebooted after every single file.

    And now guess what: The problem didn’t occur…

    So it’s not a specific ROM causing it, but something else, maybe some weird combination of ROMs or their names in different folders. I can’t figure out a pattern here.

    I also tried to start emulationstation with a “–debug”-switch at the shell, hoping this might output more information in its logfile, but it doesn’t.

    // EDIT:

    I created an issue on Github for this:

    Post count: 4

    Got it: The problem occurs if you have ROMs for a lot of (respectively “too much”) systems; It has nothing to do with the ROMs themselves.

    The background images for each system are (respectively “were”, see below) quite big and they are all loaded into the VRAM when ES starts. Depending on the background graphics for each system, the problems started if you had ROMs for around 17 different systems.

    Nils fixed that by reducing and optimizing the blurred images from 1080p to 720p (see to reduce the amount of used VRAM by ~50%.

    I tested it – it’s still too much for 23 systems, but as a “quick & dirty” workaround you can just delete some background images for some systems in the “simple”-theme (/etc/emulationstation/themes/simple).

    So if you run into this problem, you can do the following:

    Exit ES (F4)

    cd ~
    mkdir dl_tmp
    cd dl_tmp
    sudo mv index.html /etc/emulationstation/themes/
    cd ..
    rmdir dl_tmp
    cd /etc/emulationstation/themes
    sudo rm -rf simple
    sudo unzip
    sudo rm
    sudo reboot

    If it still won’t work, as said delete some .png and/or .jpg images in some system folders in /etc/emulationstation/themes/simple. You’ll just have a white background for those systems then, but everything else will be fine.

    Post count: 5

    Fixed my issue!

    Post count: 13

    Mine too – Thanks

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.