jadawan
Participant
Post count: 6

Wow, thanks for getting back with me. Keyboard and XArcade are hooked up via USB. I tried just having the XArcade plugged in so it didn’t think it had two keyboards attached. Still no luck. I know the XArcade is at least working to some extent. I can use it to type in terminal and certain buttons will speed up NES and SNES emulators, and put it in slow motion. But mapping it out seems to do nothing. Here are the relevant lines in retropie.cfg

# Keyboard input. Will recognize normal keypresses and special keys like “left”, “right”, and so on.
# Keyboard input, Joypad and Joyaxis will all obey the “nul” bind, which disables the bind completely,
# rather than relying on a default.
input_player1_a = “z”
input_player1_b = “lshift”
input_player1_y = “lctl”
input_player1_x = “lalt”
input_player1_start = “keypad5”
input_player1_select = “c”
input_player1_l = “space”
input_player1_r = “x”
input_player1_left = “keypad4”
input_player1_right = “keypad6”
input_player1_up = “keypad8”
input_player1_down = “keypad2”
# input_player1_l2 =
# input_player1_r2 =
# input_player1_l3 =
# input_player1_r3 =

input_player2_a = “w”
input_player2_b = “e”
input_player2_y = “a”
input_player2_x = “s”
input_player2_start = “num6”
input_player2_select = “]”
input_player2_l = “q”
input_player2_r = “[”
input_player2_left = “d”
input_player2_right = “g”
input_player2_up = “r”
input_player2_down = “f”

Hope that’s enough info.