Homepage Forums RetroPie Project Everything else related to the RetroPie Project Problems setting input: Wired Xbox 360 Controller Reply To: Problems setting input: Wired Xbox 360 Controller



Had the same problem, but now my Retropie is up and running with my 360 controller. I had a few hickups, but hey, I got mine working.

This is what I had to do (wired controller):

Download+install the driver (you’ll need internet connection for this);
sudo apt-get install xboxdrv

Edit the rc.local
sudo nano /etc/rc.local

add this text (just before the last line that says exit 0);

xboxdrv --trigger-as-button --id 0 --led 2 --deadzone 4000 --silent &
sleep 1

then reboot;
sudo reboot

After Retropie has restarted, exit to the command prompt with F4.
You should notice that there is only 1 light lit on your controller.

cd ~/RetroPie/emulators/RetroArch/tools
./retroarch-joyconfig -o p1.cfg -p 1 -j <strong>1</strong>

If you follow the original instructions, you would use
./retroarch-joyconfig -o p1.cfg -p 1 -j 0
When I’ve used this line, the raspberry tried setting up controls with my keyboard. To use the x360 controller for setup, I needed to change this number to one.

The next thing I did was;
sudo cat p1.cfg >> ~/RetroPie/configs/all/retroarch.cfg

But this didn’t seem to do much. Even with extra permissions;

sudo chmod 777 RetroPie/configs/all/retroarch.cfg
sudo cat p1.cfg >> ~/RetroPie/configs/all/retroarch.cfg

These commands didn’t do anything for me. So this is what I did:
sudo reboot

After rebooting and starting up, press F4 and use this command:
Having a mouse connected at this point will make things much easier :)

Then look for the file browser and go to /home/pi/RetroPie/emulators/RetroArch/tools
In there you should find the file p1.cfg (You made this yourself)
Open this file with leafpad (or another text editor) and copy the text
Leave this text file open, as it seems to be impossible to copy this text if the file is closed.

Then go to:
Open the retroarch.cfg file with your text editor, and paste your text in here.

Now all you have to do is log off and reboot, and see if this has worked for you.
Let me know if you had any results with this.