Post count: 6


So finally after many investigation and thanks to some ideas coming from your link, petrockblog I may have understood the error.

In fact, I think it came from… my berryboot installation !
I checked the code of the RetroPie script for the driver installation and saw that everything is based on the command ‘uname’ to determine the current linux kernel version.
That’s fine, excepted that the uname command was ALWAYS giving me 3.6.11-rpi-aufs, whatever the firmware that I compiled in raspbian! After some search on internet, I discovered that berryboot seems to manage alone the /boot directory and mount it when launching an image.
In my case, berryboot was launching the retropie image, mounted its own partition (and its firmware) into /boot and strangely, no firmware update was throwing an error… it’s like if the firware update worked, but the active firmware was still version 3.6 (from /boot, i.e. berryboot installation).

I starting everything again from a SD formating, using NOOBS to do a dual boot with OpenElec and Raspbian (where I installed RetroPie). The firware updates worked fine, the unmae command gave me the good versions and the driver update was successfull.

Conclusion, a BerryBoot boot of the RetroPie image may be incompatible with the current script to install the GPIO driver. Does anyone boot successfully RetroPie after a BerryBoot startup ?

: hope this helps?