Raygan Kelly

I downloaded and compiled the SDL dispmanx library as instructed:

mkdir /home/pi/RetroPie/supplementary/dispmanx
cd /home/pi/RetroPie/supplementary/dispmanx
git clone –depth=0 git://github.com/vanfanel/SDL12-kms-dispmanx.git
cd SDL12-kms-dispmanx
nano Makefile

// Now we need to edit the Makefile – there is a better way to do this I think but it works…
// Append this to CFLAGS -I/opt/vc/include/interface/vmcs_host/linux
// Save and exit

// Run configure

// Run make – DO NOT install – will break emulationstation and overwirtes some of your sdl library files

Then I skipped the stuff about recompiling EmulationStation. I’m not sure why it was reccomended and when I tried it it broke EmulationStation, so I just reinstalled EmulationStation from sources and skipped on to changing the es_systems.cfg file to use the Dispmanx library instead of standard SDL when using DGEN.

Edit your es-systems.cfg file to use this for DGEN:

COMMAND=export LD_LIBRARY_PATH=”/home/pi/RetroPie/supplementary/dispmanx/SDL12-kms-dispmanx/build/.libs”; /home/pi/RetroPie/emulators/dgen-sdl/dgen %ROM%

Worked for me anyway. I still can’t get it to fill the composite screen or exit from the controller but it’s totally playable.