mors3
Participant
Post count: 10

Think I might have gotten to the bottom of it, doesn’t make a great deal of sense, but there’s little else left that it can be.

So, I downloaded the image of RetroPie 2 (the raspi2 flavour) and applied it to my sdcard, booted to that (rather than the USB HDD) keeping only the keyboard and game controller on the USB ports and the keyboard and game controller were still unresponsive.

This has previously worked perfectly with all the same things, the game controller, the pi2, the same tfs sdcard, the keyboard, all of it, which leads me to suspect there’s actually a fault with the USB Bus on the pi itself, which although it’s initial lookup works fine, actually binding at a deeper level is failing.

The keyboard is likely to be seen as a simple HID device (or whatever the flavour is on linux, I’m speaking from windows knowledge) which as I recall doesn’t require any deep interrogation, whereas when I run retroarch-joyconfig (I think that’s what it’s called) it says it cannot find the device (yet it’s shown when I run lsusb).

So, I’ve thrown £30 at amazon for a new pi2 and I’ll test again when the new one comes in.

Cheers loads for the help on this. It’s been properly odd.