mors3
Participant
Post count: 10

…wow, I clearly didn’t explain this very well at all! Apologies :S
I really appreciate your help on this, I’ll try and explain as best as possible.

Ok, so to avoid burning out a sdcard, (and also to give me a lot more space) my raspi2 is going to be running RetroPie from an external usb hdd.

It’s most definitely being used on a raspi (a raspi2 specifically), I’m only using ubuntu purely to write the image onto the external usb hdd.

RetroPie is essentially completely unresponsive when the first Welcome screen appears (after the RetroPie splash loader screen), in the text on the welcome screen it specifically says ‘no controllers found’ and just to check I held down a couple of the buttons on the usb game controller for a couple of seconds to ensure it didn’t then start the normal assign buttons (up, down, left, right, start, select etc).
Also, pressing F4 on the keyboard doesn’t then quit out of RetroPie back to the command prompt, the only way I’ve found to actually quit RetroPie back to commandline is to ssh into the Pi and ‘ps -ef | grep retropie’ to find the PID (Process Id) and then ‘kill X’ (where X is the Process Id of RetroPie).
This then returns me back to the commandline prompt on the Pi where the keyboard works perfectly normally.

Incidentally (but quite importantly), I’ve checked my usb devices by running ‘lsusb’ and it shows my usb keyboard and my usb game controller (along with the usb hub, the mouse on my usb hub and the usb mass storage device used by the external usb hard drive).

Finally, in case it was something to do with the way the raspberry pi’s usb hub was working with the actual usb hub I’ve plugged into it, I’ve also tested the usb keyboard and the usb game controller plugged directly into the raspi and separately the usb hub, same result both times, the keyboard and the game controller remain unresponsive with the welcome screen when RetroPie starts up.

This isn’t a issue with (somehow) assigning devices too quickly either, as I’ve run up RetroPie, ssh’ed into the pi, quit out of RetroPie and then started it up again by running ’emulationstation’ and the retropie welcome screen still is unresponsive to my keyboard and game controller.

What is confusing me is that this is has been a project of mine for quite a while, I’ve been prototyping this for the last few months using an old IDE 2.5″ hard drive on a different USB mass storage interface (the current hard drive is SATA using a different USB mass storage interface) and for my initial prototyping test I imaged the drive with the standard raspbian image, then downloaded and used the github hosted retropie_setup.sh script and everything went perfectly, with absolutely no problems like this I assigned the controller, copied some psx roms (and a bios) onto the pi and even played some games on it! (it’s currently carefully laid out all over my workbench in my garage, and there’s a quiet satisfaction with playing Tony Hawks Pro Skater amidst woodshavings and blobs of solder)

The only thing that’s different between then and now is the USB mass storage adapter, the actual 2.5″ hard drive it’s plugged into and the timescale between then and now (somewhere between 4-8 weeks between the retropie setup script I’ve been running over the last week and the first time around where everything worked smoothly).

Any ideas, any thoughts or suggestions at all would be greatly appreciated.
It’s so close to being finished it’s galling.