patrickm
Participant
Post count: 171

[quote=97705]Hi

When I set any overlay option in Retroarch.cfg games wont run, PSX games do run but overlays are not displayed and if I try to change any overlay option in the settings (for example if I try to turn them off or change the scale) in the retroarch menu it crashes the PSX emulator

Just to be clear, this only happens when I set then by default in Retroarch.cfg if I run the emulator without any overlay option set in retroarch.cfg and then manualy add them in the setting menu of retroarch they do work fine.

The Retroach.cfg I edited is the one at /opt/retropie/config/all/

Any idea what could it be? having to add the overlays every time I start a game is a chore :(

Im using a PI 2 with Retropie 3 beta 2

Thanks

[/quote]

This sounds like something in your config is amiss. I wouldn’t recommend messing with the config in /all/. You have to set a different resolution for each system for the scanlines to look right, anyway. Just set integer scale on (video settings) and then set a custom resolution (options -> video options) to your liking. Then apply the overlay and save the config (main menu -> save new config). You only need to set up each system once. Go to the folder in /opt/retropie/configs/ and open the folder corresponding to the emulator. Rename the “emulatorname.cfg” to “retroarch.cfg.”

Also, make sure your video output is set up correctly by holding x when the game launches. Your video output should be at your monitor’s native resolution and retroarch render resolution should match this (set to “use video output”).

Make sure that everything is named correctly – the .png and .cfg for the overlay you’re using should be named the same, and in the .cfg for the overlay it needs to be pointing to the right filename.