trixster
Participant
Post count: 76

Are you running RetroPie 3.0 or later? I cannot help you with RetroPie 2.6.

I got this to work on a Rpi2 with 3.5″ resistive PiTFT.

I did not edit /etc/init.d/asplashscreen as it does not exist on my install. Instead I edited /etc/rc.local:
————————————–

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will “exit 0” on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Print the IP address
_IP=$(hostname -I) || true
if [ “$_IP” ]; then
printf “My IP address is %s\n” “$_IP”
fi

/usr/local/bin/fbcp &

exit 0
——————————-

the end of my config.txt looks like this:

————————-
# — added by adafruit-pitft-helper Wed Apr 15 15:11:37 UTC 2015 —
[pi1]
device_tree=bcm2708-rpi-b-plus.dtb
[pi2]
device_tree=bcm2709-rpi-2-b.dtb
[all]
dtparam=spi=on
dtparam=i2c1=on
dtparam=i2c_arm=on
#dtoverlay=pitft35r,rotate=90,speed=42000000,fps=20
# — end adafruit-pitft-helper Wed Apr 15 15:11:37 UTC 2015 —

hdmi_force_hotplug=1
hdmi_cvt=480 320 60 1 0 0 0
hdmi_group=2
hdmi_mode=87

dtoverlay=pitft35r,rotate=90,speed=80000000,fps=60
———————————————-

You would have to change the “pitft35r” to pitft28r for a resistive screen or pitft28c for a capacative one. You will also need to change the hdmi_cvt line to match your screen’s dimensions.

It’s probably best not to bump up the fps and speed too much – maybe use the # commented line for dtoverlay rather than the line i’ve added at the end. And DO NOT overclock your core beyond 250Mhz. Mine will not work with any form of core overclock.

My overclock settings are:

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1100
over_voltage=4
sdram_freq=483
force_turbo=1