halgeir
Participant
Post count: 2

Hi.

(I have the Raspberry Pi 2 Model B, with retropie v3.0 beta2 on it and I have these controllers http://www.ebay.com/itm/291352700689 – though that shouldnt matter since they work until I start a game, and I’ve tried a ton)

I have the same problem. My D-Pad doesn’t work “in-game” , but it works in the menu etc. I’ve tried what’s been written above, copy/pasted the files into my current files, but without any success.
Though I have not changed (don’t know if it’s the correct one or even if I’m supposed to change that one) /opt/retropie/emulators/retroarch/retroarch.cfg it just says permission denied.

On the other hand, I have changed the /opt/retropie/configs/all/retroarch.cfg with the text posted above. I have also changed the /opt/retropie/emulators/retroarch/configs/USB_Gamepad_.cfg with the text above.

Nothing seem to be working, the D-Pad still doesn’t work.

T

To fix it though I deleted all the automatically created config files and let it create a new one. This time it worked perfectly with my SNES controllers working without the need to go near the retroarch.cfg file.

Which files is that exactly? Because I have no idea about this stuff.

If you are using Version 3 Beta 2 I am starting to think there might be a problem with the autoconfig files.

My fix was as follows:
1 – Backup all files under config
2 – Delete them all
3 – Reconfigure each joypad using RetroPie Setup script and Joystick setup

EDIT: Just saw this one. I tried (Im accessing it through filezilla etc, hope thats the correct way to do this?) to delete the files, but I keep getting the ”Permission Denied” error…

EDIT: Found it on the forum:

for mame4all-pi, other emulator edits
sudo chown -R pi:pi /opt/retropie/emulators/

But still doesn’t work. Just reinstalled retropie and doing everything again to see if it helps.

EDIT:

Ok, so I reinstalled the whole thing. Then deleted all the config files /opt/retropie/emulators/retroarch/configs and rebooted – now nothing worked, even after input configure.

Then put the config files back and edited USB_Gamepad_ in the config folder, and the retroarch.cfg file in /opt/retropie/emulators/retroarch and in /opt/retropie/configs/all.

Still… D-Pad doesn’t work.

Hopefully you guys can help me out!