gizmo98
Participant
Post count: 452

If you had already run…
# ./retroarch-joyconfig >> ~/RetroPie/configs/all/retroarch.cfg

…check your retroarch.cfg.

There could be duplicates of the following settings:
input_player1_joypad_index = 0
input_player2_joypad_index = 1
input_player1_b_btn = “2”
input_player1_y_btn = “3”
input_player1_select_btn = “8”
input_player1_start_btn = “9”
input_player1_up_axis = “-1”
input_player1_down_axis = “+1”
input_player1_left_axis = “-0”
input_player1_right_axis = “+0”
input_player1_a_btn = “1”
input_player1_x_btn = “0”
input_player1_l_btn = “6”
input_player1_r_btn = “7”
input_player2_b_btn = “2”
input_player2_y_btn = “3”
input_player2_select_btn = “8”
input_player2_start_btn = “9”
input_player2_up_axis = “-1”
input_player2_down_axis = “+1”
input_player2_left_axis = “-0”
input_player2_right_axis = “+0”
input_player2_a_btn = “1”
input_player2_x_btn = “0”
input_player2_l_btn = “6”
input_player2_r_btn = “7”

Your joypad config should be at the end of the file. Disable all duplicates with “#”.