goremachine
Participant
Post count: 3

Yes, RetroPie/ ofc. I am always mixing up Pie/Arch, also when writing my configs.
The black borders are most likely from the overscan_scale=1.
You can remove it again, reboot and see what happens.
If there’s nothing cut off you’re good.
If there are portions of the display cut off again, you can manually change them with:
overscan_left=20
overscan_right=12
overscan_top=10
overscan_bottom=10

Just change the numbers until it fits.

I run my Pie on various displays and multiple emulators so i set it to overscan_scale=1. Sometimes there are black borders, sometimes it fits nicely.

I also have a runcommand.sh that allows 720p, not only VGA and 1080p, to have a compromise between speed/quality when using GLSL shaders for emulating old CRT/LCD/Phosphor displays.

So it also depends on the resolution chosen.

However your display looks like it is a 16:9.
The image shown is 16:9 just cropped as well.
If thats SNES it’s wrong. SNES should result in a 4:3 :(

I had a similar problem when running in VGA mode, the aspect ratio never was constrained, it always changed to 16:9.

edit your /home/pi/.emulationstation/es_system.cfg
Find the SNES section.
there is a COMMAND= section.
there you should see .…./…/runcommand.sh 1 part
The 1 means to use VGA mode.
Change it to a 2. Then it’ll keep the HDMIs native resolution, or the one you forced in boot/config.txt

Once I changed from VGA to 1080/720, constraining the aspect ratio to 4:3 worked.
However, I have changed my /RetroPie/supplementary/command/runcommand.sh to be able to switch to 720p.

If setting graphicsmode to “2” fails, or performance is too slow now due to the high resolution, report back, then I give you my runcommand.sh to switch to 720p. :)

So the summary of this wall of text:
1) You’re running VGA mode, somehow it’s streched to 16:9 and never constrained to 4:3
2) Your display is either 1080p or 720p. Change the es_system.cfg so it runs with the bootup-resolution of emulationsstation.
3) If its 1080p your pie might be too slow -> get my runcommand and force 720p, else all should work now properly.
4) If the black borders are still there but your display is now nice 4:3, try removing the overscan_scale=1 and reboot to see what you got now :D

hth.