I have this working sucesfully – it is a bit of a bodge though

All i did was delete the contents of /home/pi/RetroPie/roms so it was utterly empty after copying the directory structure to a folder on my server

Then i opened the fstab and added the following line

//servername/share/subfolder /home/pi/RetroPie/roms cifs username=,password= 0 0

This has mapped the server share/subfolder to the Roms directory so the RetroPie install does not think anything is changed, it takes a bit longer to boot but im planning on leaving it on as much as possible and once i have finished testing i will be setting it up so no logon credentials are in the fstab folder (this was a quick dirty test to see if it was possible)