boxxle
Participant
Post count: 1

[quote=4250]
P.S. I started deleting Doom, duke3d, apple2, x86, and cavestory so that the gui loads only the emulators/roms the user has access to since I’m doing a usb controller only interface. This leaves the input config left, which someone could accidentally run and reset the game-exit. Does anyone know how to disable the input config screen? Thanks!
[/quote]

To get rid of the Input Config screen, do the following from either the command line (close down EmulationStation by pressing F4) or by SSH shell:

– sudo nano /home/pi/.emulationstation/es_systems.cfg
– go to the very bottom of the file and add comment hashes like this:

DESCNAME=Input Configuration
NAME=esconfig
PATH=/home/pi/RetroPie/roms/esconfig
EXTENSION=.sh .SH
COMMAND=/home/pi/RetroPie/roms/esconfig/Start.sh

to this:

#DESCNAME=Input Configuration
#NAME=esconfig
#PATH=/home/pi/RetroPie/roms/esconfig
#EXTENSION=.sh .SH
#COMMAND=/home/pi/RetroPie/roms/esconfig/Start.sh

– hit ctrl+x
– type ‘y’ then hit enter
– done!

This should kick you back out to the command line. You can always re-enable the input config by removing the hashtags.