Anonymous
Inactive
Post count: 4

I spent most of yesterday trying to figure this out. I am only running NES/SNES, through RetroArch. My raspi is overclocked to the “high” preset with some cute little heatsinks.

I have been trying to get gpu-based shaders to work, I haven’t tried the bsnes cpu-based filters yet.

This is what I’ve learned so far:
You need to enable video shaders in home/pi/RetroPie/configs/all/retroarch.cfg:

# Path to shader. Shader can be either Cg, CGP (Cg preset) or XML/GLSL format if support is enabled.
video_shader = "/home/pi/emulators/RetroArch/installdir/bin/shaders/CRT.shader"

# Load video_shader on startup.
# Other shaders can still be loaded later in runtime.
video_shader_enable = true

I downloaded shader packs recommended in the RetroArch readme, and placed them in RetroArch/installdir/bin/shaders.

*.shader files do nothing,
*.cg filters give me a blank screen.

I tried to convert using RetroArch/installdir/bin/cg2glsl.py, but it wont work on the raspberry pi (can’t install the nvidia-cg-tools dependency, because it is x86 only).

Not really sure what to do next, so I have stopped for now.

Does anyone have a link to shaders that might work with RetroArch/raspberry pi?