supersirlink
Participant
Post count: 42

[quote=3528]I tried Petrockblog’s most recent idea of entering two commands for key pressed to be able to use hotkeys and confirmed it does not work. I can get the GPIO button to function while holding down my function key on the gamepad but mapping two button commands to one command did not provide any results. Let me know if anyone else has any ideas so we can get this all figured out![/quote]

There was an extra space after the comma after leftalt, be sure you only have one space… Also you will need to put the correct key in for the hot key assignment you made… Thats where I put two hot keys in my retroarch.cfg

I have one hot key defined for my controller and one for the keyboard. That way I can input commands from the controller OR keyboard without having to grab both…

input_enable_hotkey = alt
input_enable_hotkey_btn = 6
case BTN_STATE_PRESSED:
                                if (button.pressedCtr == 1 && button.duration >= 1) {
										uinput_kbd_write(&uinp_kbd, KEY_LEFTALT, 1, EV_KEY);
                                        uinput_kbd_write(&uinp_kbd, KEY_R, 1, EV_KEY);
                                }
                                break;
                        case BTN_STATE_RELEASED:
                                        if (button.pressedCtr == 1 && button.duration >= 1) {
												uinput_kbd_write(&uinp_kbd, KEY_LEFTALT, 0, EV_KEY);
                                                uinput_kbd_write(&uinp_kbd, KEY_R, 0, EV_KEY);

And just to confirm this worked for me… I push the momentary switch and with the assignments above, the rom resets (without having to touch the controller or keyboard)…

Thanks Florian!