Post count: 2

I think there are a couple things you can try.
You will need to edit your /boot/config.txt file
The default settings are as follows.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

It sounds like you may need to uncomment force_hotplug. If you dont know how to use vi or edit files in linux just run this.
sudo perl -p -i -e 's/#hdmi_force_hotplug=1/hdmi_force_hotplug=1/g' /boot/config.txt
That just turns this.
into this
so the pie will read it after bootup.
Reboot and see if this works.
If not reverse it running the following command.
sudo perl -p -i -e 's/hdmi_force_hotplug=1/#hdmi_force_hotplug=1/g' /boot/config.txt

Next you can try forcing the pie into 1080p mode. With the following commands. Again they are just uncommenting the variables so your machine will read them on the next boot.
Not sure where you are from so here are the NA and EU setups.

for NTSC (North American TVs 60Hz)

sudo perl -p -i -e 's/#hdmi_group=1/hdmi_group=1/g' /boot/config.txt
sudo perl -p -i -e 's/#hdmi_mode=1/hdmi_mode=16/g' /boot/config.txt

to switch back tp default from NTSC settings.

sudo perl -p -i -e 's/hdmi_group=1/#hdmi_group=1/g' /boot/config.txt
sudo perl -p -i -e 's/hdmi_mode=16/#hdmi_mode=1/g' /boot/config.txt

for PAL (European TVs 50Hz)

sudo perl -p -i -e 's/#hdmi_group=1/hdmi_group=1/g' /boot/config.txt
sudo perl -p -i -e 's/#hdmi_mode=1/hdmi_mode=31/g' /boot/config.txt

To go back to default from pal settings

sudo perl -p -i -e 's/hdmi_group=1/#hdmi_group=1/g' /boot/config.txt
sudo perl -p -i -e 's/hdmi_mode=31/#hdmi_mode=1/g' /boot/config.txt

You can see the values here.

Hope this helps you!