joyrider3774
Participant
Post count: 34

i have done exactly the same thing and that works without a problem.. my picade (usb keyboard encoder) is set to player 1 and player 2 i using my gamepad it works fine for all retroarch emulators. For mame4all you have to set it up manually using tab config.

I think although not certain withouth looking at my config (can’t check at work atm) is that you need to change / play with input_player1_joypad_index = “0” input_player2_joypad_index = “1” in retroarch.cfg i manually edited that file and it works fine. I can post my file if i come home if you like or you can try and have a look at those joypad indexes but i’m not certain it was that setting

Also in the tab config pressing Select ui button (default enter i think or a certain gamepad button) and the cancel button (default escape) sets the input to none so you can start cleanly to assign a button / direction i think i did that as well for every button where the joypad was also mapped to player 1 i just deleted those (set those to none) and then reassigned the keyboard (only) controls for player 1 for player 2 (gamepad) i did the same also