Post count: 4

[quote=101244]My setup has the joystick mappings right in retroarch.cfg. Are there some there that take precedent? I haven’t upgraded my version of RetroPie since I got it all working. So maybe the config stuff has changed since I installed.


Thanks for the reply. No, there aren’t any mappings in retroarch.cfg. Everything is commented out, and is using the config files in retroarch-joypad directory.

I also tried commenting out this line in the retroarch.cfg file:
joypad_autoconfig_dir = /opt/retropie/configs/all/retroarch-joypads/

…then I added the mapping directly to the retroarch.cfg file. Still no luck.

The retroarch-joypads directory is owned by pi:pi with 755 perms. My config files within that directory AND the retroarch.cfg file are both owned by pi:pi with 644 perms. The parent directory (/opt/retropie/configs/all) is also owned by pi:pi with perms 755. So, the user pi has read and write permission for everything. Can someone confirm the permissions on these files and directories?

I checked for any other “retroarch.cfg” files on the system, and didn’t find any others besides what is in /opt/retropie/configs/all/* (did via “find / -name ‘retroarch.cfg’). So, I don’t think any other config files are taking precedence.

As it sits today, I only have joystick operations and A/B button working now. It doesn’t matter what I do to the retroarch.cfg file, nothing changes.

Are there any logs for emulationstation or retropie? Can I add some debug flags to get more information on the config file being called? I don’t see any information being logged to /var/log/messages that are useful.