Post count: 7

[quote=100876]I also am using a Dualshock 4 (PS4) controller, and had the same issue, but I finally found out a solution!

After looking through some of the setup options, one of the options was Install Retroarch autoconfigs (or something like that, it was very similar). I decided to just give it a whirl and install this, and it ended up working! I rebooted my Pi, went into Super Mario World for SNES and it worked perfectly.

Also tested on The Legend of Zelda Minish Cap for GBA. Works fine! I hope this helps!

I did not have to go back in and configure the controller manually after this. I just rebooted my Pi and it was already configured correctly.


Thanks for the help, Falcon! :D
For anyone that couldn’t find the option, it’s located at:

Retropie menu, retropie-setup
"setup/config (to be used post install)"
[Option 318] "Install Retroarch joypad config"

Now the joypad almost works!

What I find peculiar is that now I have 3 dragonrise cfgs:


(these ones where created “manually” while trying to setup before)

(these where download automatically, and are almost empty. The GenericUSB one only have “input_driver = “udev”)

And Retroarch is reading… That one the I created before! Very weird.
I’m sure of that, because I placed the code to go back to the ES menu pressing select+start, reset emulator, etc, inside this one, and he can understand that.

But I still can’t make my analogs work. Here is the analog part of the code (auto-generated by the retroarch joy config before):

input_l3_btn = "10"
input_r3_btn = "11"
input_l_x_plus_axis = "+0"
input_l_x_minus_axis = "-0"
input_l_y_plus_axis = "+1"
input_l_y_minus_axis = "-1"
input_r_x_plus_axis = "+3"
input_r_x_minus_axis = "-3"
input_r_y_plus_axis = "+4"
input_r_y_minus_axis = "-4"

Again, I tried to place it inside each of dragon’s cfgs, placing it inside “\\RETROPIE\configs\all\retroarch.cfg”, “\\RETROPIE\configs\psx\retroarch.cfg”, etc

I’m starting to think that this code have something wrong, but I can’t really understand what :o Maybe the axis notation?

I’ll keep trying to figure out what is the problem, but any help is appreciated :)

I discovered how! :D Thanks to this video from TechTipsta:

His video is more indepth, configuring the .cfgs using a usb keyboard, directly on the Raspy. But you can do all using a wifi dongle, and sharing your config files via samba (already comes preconfigurated, at least in this version of retropie [v.3.0, beta 4])

First, you need o configure 2 Retroarch specific buttons: one to toggle the hotkeys, another one to bring the retroarch config menu.
On the video, he used select + f1 (the f1 is already on the “\\RETROPIE\configs\all\retroarch.cfg”, but it’s commented by default; you just need to open it, and uncomment the line, deleting the “#” in front of it), but you can use any button from your controller. can use any button you wish.

In my case, I used the select + the equivalent of the triangle button on my generic controller. This code goes inside your gamepad cfg, located in


I’m my case, the code is:

input_enable_hotkey_btn = "8"
input_menu_toggle_btn = "0"

After that, you just start the psx emulator, push your enable_hotkey button, the input_menu button, and voilá, you should bring up the retroarch menu.

Now, you should be able to use your keyboard or your joypad to navigate thru the menus. But when I tried to use the joypad, the menus goes ballistic, and I can’t select anything. So, keep your keyboard with you, just in case! You are looking to go to:

options> core options> pad1 type

Change the pads type from STANDARD to ANALOG

Now just go back 1 menu, select “resume content”, and you are done! :D
I still have to test if this config “sticks” after shutting down the PI, and this menu have many more options to mess. I’ll edit this post in the case that I find something important! :D

Ops, it doesn’t stick. That’s what I get for skipping the video :/

After changing from standard to analog inside the core options, go back to settings > Input settings, and change “User1 Devicetype” from Retropad to Retropad w/ analog

Go back to the “root” menu, and choose “Save New Config”
It will change the “configuration files” above from retroarch.cfg to libretro.cfg. Everytime you save it again, it creates a new file (libretro-1.cfg, 2, 3, etc).

After that, exit the emulator, press f4 on your keyboar to reset the Retropie. On the command line, we will append the libretro config file to the retroarch one, so it (theoretically) load the settings everytime.

(Via samba, you can just open the 2 files, and ctrl+c, ctrl+v the settings from inside the libretro file to the retroarch one, but let’s do it the “clean” way)

Type in the command line

cd /opt/retropie/configs/psx
(in the video, the path is …/configs/all; i think it changed since them, because retroarch saved everything inside the psx folder)

Now type ls; You’ll see all the files on this directory, including the newly created libretro.cfg. To append it to the retroarch.cfg, just type

cat libretro.cfg >> /opt/retropie/configs/psx/retroarch.cfg

Theoretically, Retroarch should read this, and autoset the analog everytime. But isn’t working yet, I still need to manually change to analog everytime I restart the emulator :/

I’ll keep messing with it, but as I said before, any help or hint is appreciated :D