Forum Replies Created

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • bairdo
    Participant
    Post count: 9

    @Cacophony

    I will take pics when I get home. I am getting the roms from various sources – not all the same place. I don’t know if they are good sources or not, I’m just searching google.

    I am going to try to do what trimtrabb has done and see if I can at least get them running — not sure how to change the script but will try to figure that out!

    bairdo
    Participant
    Post count: 9

    @cacophony Sorry – again I’m a noob. To clarify: I should try running ./mame and the different roms and then type up the response code that is given (such as “no such game”), or is the console output something else?

    I have tried about 6 different roms, all say they are for mame, two specifically say they are 0.37b5 file versions. I have found a few more tonight that I will try when I have time tomorrow.

    bairdo
    Participant
    Post count: 9

    @cacophony

    I had originally tried the roms – both as .zip and unzipped – in the original /home/pi/RetroPie/roms/mame directory and none of the versions I had used worked. Is there any more info that I could give you that might help, or another build you might suggest?

    bairdo
    Participant
    Post count: 9

    @cacophony

    tried making roms directory in original mame4all-pi folder, no go.

    So I put the unzipped folder into “RetroPie” directory, and tried to launch with ./mame – no such file or directory. same when I try chmod. Should I be putting the mame4all-pi folder into another directory? Sorry for so many questions, I am really just starting out with this and hit the road block with galaga not working.

    Also, if I do get this working, is there a way to clean boot the pi into the galaga/mame4all-pi rom?

    edit: I was able to put the zip file in home>pi and successfully unzip and run the emulator with the commands you gave, however it still will not run galaga. When I ./mame it opens and says no roms available, when I ./mame galagamame (both .zip and unzipped files are in roms directory) it flashes the screen then says “game ‘galagamame’ supported”. It is a 0.37b5 file version

    bairdo
    Participant
    Post count: 9

    I have tried .37b5 roms and rom sets zipped and unzipped. I think that the issue is not knowing where the emulator is looking for its data. The default mame emulator (I think advMAME) is not reading any of the roms, and the “rom” folder for mame4all-pi is nowhere to be found. I have looked both in the home>pi>RetroPie>roms directories, as well as the home>pi>RetroPie>emulators>mame4all-pi directory. There is no “rom” folder or “mame4all-pi” sub-folder in “roms”.

    I never installed the emulator – I am just using the current version of RetroPie which has mame4all-pi on it. When I run the .exe from the GUI it runs but tells me there are no roms.

    I don’t know if reinstalling the emulator would re-create the source path if it is missing, but I don’t know how I would go about re-installing as it is no longer available in the pi store and I’m a complete noob. I’ve downloaded it from the source site and transferred it to my pi, but don’t know where to go from there.

    bairdo
    Participant
    Post count: 9

    that’s what I mean though – there is no “roms” folder in the directory with that exe. i’m in “root>home>pi>RetroPie>emulators>mame4all-pi” and the options are folders, obj_mame_rpi, skins, src, .git” in “folders” there is just a txt file, “obj” and “src” have a bunch of sub folders – none called “rom”, “skins” has “source” with nothing in it. I’m not sure where the exe would be looking for the rom files.

    bairdo
    Participant
    Post count: 9

    Sorry – I am a super noob and am not sure what you mean by the relevant es-systems.cfg lines

    I have tried running through the emulation station but the emulator doesn’t show up as an option – I think the mame option that is showing up is advMAME and isn’t opening anything.

    When I go into startx I can find the mame4all-pi emulator and execute it, but it says no roms are available. I can’t find the rom folder for mame4all-pi anywhere – I have looked all through the emulator folder as well as the emulatorcores folder

    bairdo
    Participant
    Post count: 9

    Hey – so I feel like a total moron, but I’m having a huge issue with loading roms in MAME in my pi.

    I just put retro-pi on, and it is up and running. I have tried 3 different rom versions of galaga (the whole reason I am building the arcade) and none of them are working. I am putting the files into the “mame” folder under the roms subdirectory. They show up, but won’t run. I don’t know whether this is the directory for advMAME or mame4all-pi, or both.
    – edit: have used the 0.37b5 rom, as well as other versions and none will load

    If someone could help me out with troubleshooting this I would really appreciate it

Viewing 8 posts - 1 through 8 (of 8 total)