Forum Replies Created

Viewing 35 posts - 1 through 35 (of 53 total)
  • Author
    Posts
  • atimmins
    Participant
    Post count: 59

    Sounds like it is overclocked too high. Not every setting works with every pi. Try setting it to a lower overclock level and see if your problem goes away.

    atimmins
    Participant
    Post count: 59

    Maybe it is something specific to mame. I have used backups for consoles and haven’t had any problems. One thing I did notice through, was that the overclock settings that run smoothly on one raspberry pi made a second one freeze and crash. I had to lower the overclock settings for the second one to get it to work. If your trying both the original and the backup on the same pi, then I don’t have any help for you. Sorry.

    atimmins
    Participant
    Post count: 59
    in reply to: Kodi 15 update #111638

    I had hoped it was something as simple as xbmc settings so those were the first things I tried. No luck. I think something about the kodi installation got messed up or something.

    atimmins
    Participant
    Post count: 59
    in reply to: Kodi 15 update #111572

    Anybody?

    atimmins
    Participant
    Post count: 59

    You can configure as many controllers as you like and it won’t remove any you had done previously. Currently I have three different types configured on my system.

    atimmins
    Participant
    Post count: 59

    I thought there was a way to load roms from a USB drive, but I don’t know how since I have never done it. It seems like maybe that was an added feature of one of the more recent updates. search around the forum and you might find something.

    atimmins
    Participant
    Post count: 59

    I have noticed that with win32disk imager when I choose the file I want to backup to or restore a backup from, I have to type .img the end of the file or else it doesn’t work. Try creating a backup of the working card and then writing that backup to the new card. It works for me as long as I don’t forget the .img

    atimmins
    Participant
    Post count: 59

    I only looked at it long enough to see that it reset everything instead of simply updating, but I did notice these things.

    1. I lost all previously configured controllers (I’m assuming I would have to go through the whole process again of configuring my 8bitdo bluetooth controller)
    2. Unused emulators were added back to the home screen
    3. Emulator specific configs (ie shaders etc) were overwritten with defaults

    I’m not sure if this is the case, but suspect it is, that it also removed Kodi and my lirc settings which allowed me to use a ir remote control. It is not worth “updating” if I have to reconfigure every little thing that I have changed to get it the way I want it.

    atimmins
    Participant
    Post count: 59

    I just tried following the instructions on the link that herbfargus gave, but it did not keep any of my settings or adjustments. It did not even keep the controllers I had configured. Good thing I made a backup first. Please, anyone thinking of updating their retropie don’t it if you have made any changes at all. You may as well start with a new image and start over.

    atimmins
    Participant
    Post count: 59

    If you have spent a lot of time tweaking the settings for your use I’d say it’s not worth the effort. I wish there was a better way to update than starting with a fresh image every time.

    atimmins
    Participant
    Post count: 59

    I second this. XBMC has this functionality so it seems like it would be possible.

    atimmins
    Participant
    Post count: 59

    I have given up on this. It was a nice idea but I can’t make it work. I can successfully mount a windows folder and I can add files to the windows side and see them show up on the pi and add files on the pi and see them show up on windows, but RetroPie seems to have a problem moving the save locations to a network folder. I can move the save location to another folder on the sd card fine, but if I try to move it to a different computer on the network it defaults back to the original save location and won’t look in the network folder despite changes to the opt/retropie/configs/all/retroarch.cfg file.

    Perhaps this is something that can be ironed out for future versions of RetroPie.

    atimmins
    Participant
    Post count: 59

    I thought so, but I could be wrong. I am only able to modify the etc/fstab file with root status, so I don’t know if that is messing things up.

    atimmins
    Participant
    Post count: 59

    Anyone have an idea? I am surely not the first person to try this.

    atimmins
    Participant
    Post count: 59

    Okay so I started over with a backup and was able to change the save directory to a new raspberry pi folder. However, once I turned that new folder to a network folder on my windows computer, it gave me the same error messages as before. Were you able to make it work with a network folder on another computer? What does your /etc/fstab file look like?

    atimmins
    Participant
    Post count: 59

    Here is the relevant section of the config file (if you need other sections please let me know):

    # Save all save files (*.srm) to this directory. This includes related files like .bsv, .rtc, .psrm, etc …
    # This will be overridden by explicit command line options.
    savefile_directory = /home/pi/RetroPie/saves

    # Save all save states (*.state) to this directory.
    # This will be overridden by explicit command line options.
    savestate_directory = /home/pi/RetroPie/saves

    The message I get when I try to load a save state is :

    Failed to load state from “/home/pi/RetroPie/roms/nes/Contra.state”.

    As you can see, it is still trying to find the save state file in the default location, but it is unable since I moved them all over to /home/pi/RetroPie/saves. I suspect that if I copied the save file and pasted it back in the default location it would work fine. Does it not allow roms and save files to be stored in different folders?

    atimmins
    Participant
    Post count: 59

    When I save a game it saves to the old location as it used to. When I try to load a save state it gives an error saying it can’t find the save file in the old location (because I moved all the save files to the new location).

    atimmins
    Participant
    Post count: 59

    You have to set up hotkeys in your controller config file. You should add the following lines:

    input_enable_hotkey_btn = “0”
    input_exit_emulator_btn = “9”

    This would exit the emulator when you press start while holding down select. If preferred you can change either value to any other button you would rather use.

    atimmins
    Participant
    Post count: 59

    As far as I know, Street Fighter doesn’t use button combinations involving start and select. The whole point of hotkeys is that you hold down a button and then press down another button to perform the action you want. If the hotkey you are trying to set up is to exit the emulator, just set it so you hold down select and then push a shoulder button or something.

    atimmins
    Participant
    Post count: 59

    I was able to update the firmware on my controller with a Windos 7 computer, however, ever since the update, it will not connect over Bluetooth. I tried repeating step 4 of Floob’s guide, but it tells me that device already exists and fails to connect. I even tried uninstalling bluez-utils blueman and bluez python-gobject and reinstalling them, but it made no difference. any ideas?

    atimmins
    Participant
    Post count: 59

    Floob, unfortunately I haven’t been able to update the controller firmware. It that maybe it doesn’t work with Windows 10 because the update button is always grayed out and cannot be clicked.

    atimmins
    Participant
    Post count: 59

    Can you use some other button as your hot key?

    atimmins
    Participant
    Post count: 59

    For those of us who are inexperienced, can you please explain how you fixed the issue in RetorArch? I have the same issue. I have a wireless bluetooth controller I would like to always be detected as player 1, regardless of whether or not other controllers are plugged in.

    atimmins
    Participant
    Post count: 59

    Most people use hotkeys set up so that you have to hold down select then press another button to do the action they want. Most people do select + start to exit the emulator and select + left/right to load/save save states.

    atimmins
    Participant
    Post count: 59

    To the original poster, did you ever get this to work? I just got my 8bitdo SNES30 controller set up last night. I used the guide found at https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-Bluetooth-controller.

    I had the controller connect via bluetooth within about 20 minutes. That was the easy part. The trouble that I had was that the buttons seem to be different for controlling emulationstation (selecting games and systems) than for controlling the actual games.

    The trick I found was that the config for emulationstation is found at /home/pi/.emulationstation/es_input.cfg and uses the button numbers you got from step 5 of the guide. For whatever reason, I was unable to program the d-pad directions, but they just worked already. The config for actual games is found in /opt/retropie/configs/all/retroarch-joypads and is created in step 6. Don’t try to use the same button numbers in the two config files or it won’t work.

    I am still having trouble trying to get the shoulder buttons to work as hotkeys for loading/saving save states, but otherwise it works great. Hopefully this helps.

    atimmins
    Participant
    Post count: 59

    I have the SNES30 controller which works fine in emulationstation and in games, but I can’t seem to get the hotkeys to work for saving and loading save states. The controller config file at opt/retropie/configs/all has the following lines but they don’t seem to work;

    input_save_state_btn = “18”
    input_save_state_btn = “17”

    I know hotkeys have been enabled because it works to push select + start to exit the emulator. All the hotkeys for my original SNES controllers plugged in to a usb adapter still work fine.

    Is there some reason that I can’t use the shoulder buttons on the SNES30 controller for hotkeys? I saw a post on some other forum where someone said he could never get the shoulder buttons to work either, so he had to re-map the hotkeys to something else.

    Also, if my usb controller is plugged in and I used the 8bitdo controller, it will select the game from emulationstation, but I lose control once in the game. I’m guessing that it assumes the usb controller is player 1. Is there a way to make the 8bitdo controller have priority for player 1?

    atimmins
    Participant
    Post count: 59

    I have been working on this tonight and wanted to say that you guys were right and I was wrong. Adjusting the overscan values and adding overscan_scale=1 seems to have fixed my problem. It seems that in my ignorance of raspberry pi and Linux that I set my initial overscan settings incorrectly. I assumed that I was supposed to make the command line text flush with the edges of the screen. I can see now this was incorrect. Thank you all for your suggestions and help.

    atimmins
    Participant
    Post count: 59

    Okay, two questions. First, are you saying that I need the overscan_scale=1 line four times, one for each overscan value (top, bottom, left, right)? Second, if I change the overscan values to correct emulationstation, am I doing at the expense of having correct overscan values for the command line interface? The values I originally posted are what work for my TV to get the correct screen size for command line. I figured that since I was able to see all of the command line image without borders then emulationstation should work the same. Obviously that isn’t true.

    atimmins
    Participant
    Post count: 59

    [quote=105632]

    I tried working on this over the weekend. I tried adjusting the frame buffer values and tried disabling overscan without success. I found that removing the line “overscan_scale=1″ from my config.txt file helped a little bit. Now I can see about half of the emulationstation menu. It seems like adding this line is the only thing that has helped everyone else, so I am out of ideas.

    you need to add overscan_scale=1 in conjunction with the various overscan_left/etc settings. your settings from above:

    overscan_left=23
    overscan_right=-20
    overscan_top=-20
    overscan_bottom=-10
    overscan_scale=1

    if ES is running OVER the edge of the screen, you should be using positive numbers. negative numbers exacerbate the problem – they’re for when you have a black border around ES. so it makes sense to me that if you remove overscan_scale=1, you see more, assuming you’re still using the above set up.

    try:
    overscan_scale=1
    overscan_bottom=20 (rather than -10)

    if that works i’d probably do the same with the other overscan_’s – you’ll probably find they all need the same number.

    [/quote]

    The config file you quoted isn’t mine. It was posted by someone else. As I mentioned in my last two posts, I have already tried overscan_scale=1 in conjunction with overscan left, right, etc values and it makes no difference. In my particular setup, overscan_scale=1 seems to make the problem worse. Removing that line allowed me to see a little more of the screen, but I still have an overscan problem.

    atimmins
    Participant
    Post count: 59

    My overscan_scale was set to 1 from the beginning and emulationstation refused to honor the overscan settings. Removing the overscan_scale line was the only thing that gave any marginal improvement.

    atimmins
    Participant
    Post count: 59

    I tried working on this over the weekend. I tried adjusting the frame buffer values and tried disabling overscan without success. I found that removing the line “overscan_scale=1” from my config.txt file helped a little bit. Now I can see about half of the emulationstation menu. It seems like adding this line is the only thing that has helped everyone else, so I am out of ideas.

    atimmins
    Participant
    Post count: 59
    in reply to: Cheats working? #105363

    You could try it yourself and then tell the rest of us.

    atimmins
    Participant
    Post count: 59

    I don’t think the /boot/config.txt file has been changed by lirc. What is really bothering me is that the overscan problem is only within Emulationstation and individual emulators. The command line interface shows up fine and follows the overscan settings in the config.txt file. The RetroPie splashscreen and Emulationstation loading screens look fine, but once Emulationstation opens up, I can’t see the entire screen. I had this problem previously with RetroPie version 2.4. I did a fresh install of version 3.0 and things looked fine until lirc started working. Now it is behaving exactly like it did previously.

    atimmins
    Participant
    Post count: 59

    It is hooked up to a 65″ mitsubishi DLP TV with HDMI. I have tried 480p and 1080p hdmi modes and haven’t noticed any change. Would installing lirc have anything to do with this? I can’t imagine that it would, but it was weird that the problem only showed up after getting lirc running. I also noticed overscan in Kodi (xbmc) right after lirc started working. That was easy enough to fix with video calibration settings in Kodi though.

    I have also tried modifying the full screen settings in the retroarch.conf file like this:

    video_fullscreen_x = 0
    video_fullscreen_y = 0

    Supposedly this is supposed to force it to use the desktop resolution, but it doesn’t make any difference.

    atimmins
    Participant
    Post count: 59

    I tried adding the following lines without success:

    overscan_left=23
    overscan_right=-20
    overscan_top=-20
    overscan_bottom=-10
    overscan_scale=1

Viewing 35 posts - 1 through 35 (of 53 total)