Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • alley-cat-jack
    Participant
    Post count: 11

    Try all buttons on both controllers to see if any register. I had an issue a while ago where only 1 button would register. The problem was related to either my latch or clock wire, I don’t remember which.

    alley-cat-jack
    Participant
    Post count: 11

    If your pi was resetting, you were connecting the wrong pins on the pi together and the pi shut down because those pins should not connect.

    Can you tell us what pins you have connected to the controller ports, and what driver you are using.

    alley-cat-jack
    Participant
    Post count: 11

    Access retropie_setup by using sudo ./RetroPie-Setup/retropie_setup.sh
    Select option 3 Setup / Configuration (to be used post install)
    Select option SNESDev (Driver for the RetroPie GPIO-Adapter)
    Reboot pi after installed

    I think this will install jstest as well as the driver for the adapter. It should enable your controller ports though. It looks like you have it wired up correctly, just be sure none of those wires are shoring with others. Be sure you connect it in the correct direction on your adapter however as well as connecting the adapter to the pi in the correct direction.

    alley-cat-jack
    Participant
    Post count: 11
    in reply to: strange behaviour #108312

    What kind of controller are you using?
    Is it a 3rd party controller?
    Have you tried a different controller?
    Does the problem happen when no controller is connected at all?
    Is the problem present in all emulators?
    Does the problem occur in EmulationStation menu?

    alley-cat-jack
    Participant
    Post count: 11

    Look’s like the answer to the pinout was pretty easy to find in the code. I was correct, the 2.0 version does have a different pinout.

    I made a quick reference for anyone else looking for this. I would still like to see a copy of the schematics if anyone has them though.

    alley-cat-jack
    Participant
    Post count: 11

    Open /boot/config.txt
    Enable hdmi_drive=2 by removing the #
    Save and Reboot

Viewing 6 posts - 1 through 6 (of 6 total)